ManufacturingKnowledge

Approving/releasing manufacturing process plans

Create a baseline of a structure

Procedure

  1. Open the structure revision.

  2. Select the top line of the structure and choose Tools→Baseline.Teamcenter checks if you can create a baseline of the selected revision. If not, Teamcenter displays the reason (for example, you cannot create a baseline from an existing baseline). Otherwise, Teamcenter displays the Baseline dialog box, showing the item ID, baseline revision, and baseline name.

  3. Enter the following information in the Baseline dialog box.

Box

Entry

Description

Type a description of the baseline.

Baseline Template

Choose a baseline release procedure template from the list of available procedures. Your administrator defines the available procedures with the Baseline_release_procedures preference.

Job Name

Note the job name. The job name is automatically generated and you cannot change it. Your administrator defines the naming scheme in the Business Modeler IDE application, as described in the BMIDE for Data Model Design.

Baseline Label

Type an alphanumeric string that represents the baseline label. Teamcenter uses the label you enter as the name of the baseline folder. This box is only displayed if your site uses baseline labels.

Job Description

Type a description of the PDI job.

Open On Create

Select this check box if you want Teamcenter to open the baseline for viewing when it is created. You must apply the revision rule manually when the baseline is open.

Dry Run Creation

Select this check box if you only want to validate the structure as suitable for creating a baseline. If you clear this check box, Teamcenter validates the structure and creates an item revision for the baseline. Note Your administrator can set the Baseline_dryrun_always system preference to determine if a dry run is always required.

Precise Baseline

Select the type of baseline to create— precise or imprecise. Your site may be configured to allow only precise baselines, depending on the setting of the Baseline_precise_bvr preference.

  1. Click OK or Apply to create the baseline. Alternatively, you can click Cancel to exit without creating a baseline.Teamcenter optionally creates a baseline folder to hold the baseline. Your administrator specifies if a folder is created by setting the baseline_create_snapshot_folder preference. If the value of this preference is 0, the baseline folder name is in the format Baseline_ItemId_BaselineRevId and may be truncated to 32 characters, if necessary. The folder is attached to the top structure.If the value of this preference is 1, the baseline folder name is the alphanumeric string you entered in the Baseline Label box in the Baseline dialog box.Note In addition to setting this preference, you must set the Snapshot relationship on the item revision to make the snapshot folder visible. Do this by choosing Edit→Options→General→Item Revision and adding Snapshot to the Shown Relations column of both the General and Related Object tabs. Caution If you expand the baseline item revision below a certain level, the application displays duplicate objects.

  2. Save the revision rule for the product structure, process structure, and plant structure by saving the structure as a collaboration context. After you do this:

The product root item is the baseline product.

The plant root item is the plant baseline.

The process root item is the process baseline.

Source: https://docs.sw.siemens.com/en-US/doc/282219420/PL20251212545240207.mse/impa1502 · retrieved 2026-07-11