Authoring manufacturing process plans
New object dialog box commands
When creating a new object using a variety of commands in Manufacturing Process Planner, you will view different dialog boxes. While they appear the same, the most recent dialog box moves the Show As New Root check box from the last screen to the first screen, and lets customize the dialog box stylesheet for different types of objects as you require. Commands include:
File→New→Item, Process, Process Area, Operation, Plant BOP, Workarea, Product BOP, Generic BOP, Logistic BOP, Study, and all items under Logistics→.
File→New→From Template→Logistic BOP from Template, Process from Template, Product BOP from Template, Plant BOP from Template, Operation from Template, Workarea from Template, and Item from Template.
Edit→In Context→Replace Assembly with Any Item Type.
The following rules apply to this behavior.
If you create an object without selecting a line in a view, the Show as New Root check box is checked and the new object is loaded automatically as a root line in a new view.
If you create an object without a non-root line selected, you can open the item as a new root in a new view by selecting the Show as New Root check box.
If for some reason the object cannot be created as a new root, the Show as New Root check box is disabled.
Note
To set a manufacturing object to use the old dialog box, set the value of the preference TC_Enable_Legacy_Create to the internal name of the manufacturing object.
Source: https://docs.sw.siemens.com/en-US/doc/282219420/PL20251212545240207.mse/xid1446878 · retrieved 2026-07-11