Viewing and managing data > Product view overview
Configure and manage product views
Procedure
Choose Options→Visualization→Product View.Teamcenter displays the Product View Creation Preferences pane.
Set the following preferences as required:
Preference
Description
Geometry Asset
Determines whether a geometry asset file is added when a product view is created. This file is required if you want to export a PLM XML file of the product view. This option is equivalent to the Vis_PV_Geometry_Asset preference.
Show Product View name dialog
If selected, you are prompted for a name each time you create a product view. If not selected, Teamcenter generates the name automatically. This option is equivalent to the Vis_PV_Show_Name_Dialog preference.
View Toggle Warning Level
If selected, Teamcenter displays a warning or prevents you from continuing if you try to create a product view when one or more of the View menu commands to show unconfigured data is selected. This option is equivalent to the Vis_PV_InvalidConfigWarnLevel preference.
View Toggles to consider
Select the View menu commands to show unconfigured data that are considered if the View Toggle Warning Level option is selected. This option is equivalent to the VisPVBlockingViewToggles preference.
Image Capture
Determines if Teamcenter saves a preview image of the 3D product view when it is created. If you choose Perform Image Capture (Using Image Export Dialog), you are prompted for the settings to use. If you choose, Perform Image Capture (with preferences), it uses values set in preferences. This option is equivalent to the Vis_PV_ImageCapture preference.
Image Format: Image Resolution, Width of image, and Height of image
Depending on the setting of the Image Capture option, these options may determine the file format, resolution, and size of the preview image. If Perform Image Capture (Using Image Export Dialog) is set, these options are disabled. These options are equivalent to the Vis_PV_ImageCaptureType, Vis_PV_ImageCaptureResolution, Vis_PV_ImageCaptureWidth, and Vis_PV_ImageCaptureHeight preferences, respectively.
Thumbnail: Width, Height, and Quality
Determine the size and resolution of the thumbnail image created for each product view. These options are equivalent to the Vis_PV_ThumbnailWidth, Vis_PV_ThumbnailHeight, and Vis_PV_ThumbnailQuality preferences, respectively.
Play motion in current view
If selected, any motion (VFM) file in the current product view plays when the view is selected. This option is equivalent to the Vis_PV_Play_Motion preference.
Configuration rule to use
Offers you two choices:
Use configuration from the current BOM ignores stored rules and preserves the configuration that was active before you applied the product view.
Use configuration from product view considers any arrangements, effectivity, variant rules, and revision rules stored with the product view when you apply it.
This option is equivalent to the Vis_PV_HowTo_Configure_BOM preference.
Note Your administrator may configure these preferences with SITE or GROUP protection scope, rather than USER protection scope. If so, you may be able to view but not change the current settings.
Right-click a selected product view thumbnail in the Product View Gallery dialog box.Teamcenter displays a shortcut menu.Note You can identify the currently selected product view by the green border (if checked out) or red border (if not checked out) around its thumbnail.
Choose one of the following.
Command
Description
New Tab
Creates a new tab for the element currently selected in the structure. This tab is unavailable if no element is selected in the structure base view window.
Refresh Tab
Refreshes the currently selected tab in the product view gallery to reflect structure configuration changes.
Remove Tab
Removes the current tab from the dialog box.
Refresh All Tabs
Refreshes all the tabs in the product view gallery to reflect structure configuration changes.
Remove All Tabs
Removes all tabs from the dialog box.
Add
Creates a new product view from the current contents of the viewer.
Apply
Applies the configuration of the selected product view to the viewer.
Delete
Deletes the selected product view.
Update
Refreshes the stored product view with changes made in the viewer. This command is enabled only if you check out the product view dataset.
Rename
Displays a dialog box that allows you to change the name and description of the selected product view. A product view name appears below each button; the description appears when the cursor is placed over the button. If you rename a product view, the order in which thumbnails are displayed in the Product View Gallery dialog box changes. Teamcenter generates the default name of a view from the date and time it was initially created. It lists available views in alphanumeric order. You can choose an appropriate new name to move the view up or down the list.
Enable Multiple Selection
Allows you to select more than one product view.
Options
Displays the Product View Creation Preferences pane.
Note If you right-click any part of the Product View Gallery dialog box (except one of the buttons) and no product view is selected, the menu commands to apply, update, rename, and delete the product view are unavailable.
Source: https://docs.sw.siemens.com/en-US/doc/282219420/PL20251212545240207.plm00043/pv0002 · retrieved 2026-07-11