Getting started with Multi-Structure Manager > Multi-Structure Manager interface
Multi-Structure Manager menus
| Menu command | Purpose |
|---|---|
| File→New→Collaboration Context | Allows you to create a new collaboration context. |
| File→New→Structure Context | Allows you to create a new structure context, which may optionally be associated with a collaboration context. The types of structure that you can create are defined by your administrator with the Business Modeler IDE application. |
| File→New→Configuration Context | Allows you to create a new configuration context, which determines the configuration of the structure to which it is attached. |
| File→New→Occurrence Group | Allows you to create a new occurrence group and add it to the current structure context or to the currently selected occurrence group. This menu command is available only if you select a structure context in the collaboration pane or a structure pane is open with no object currently selected. |
| File→New→From Template→Item From Template | Creates a new item from an existing one. |
| File→New→Item | Inserts an item into the currently selected structure. |
| File→New→Part | Creates a new part. |
| File→New→Design | Creates a new design, that is, a CAD representation of a part or assembly. |
| File→New→Snapshot | Creates a snapshot of the selected structure. |
| File→New→Folder | Allows you to attach a folder to an object in the structure context. This menu command is available only in the collaboration and attachments panes. |
| File→New→Dataset | Allows you to attach a dataset to an object in the structure context. This menu command is available only in the collaboration and attachments panes. |
| File→New→Form | Allows you to attach a form to an object in the structure context. This menu command is available only in the collaboration and attachments panes. |
| File→New→BOM View Revision | Allows you to attach a BOM view revision (BVR) to an object in the structure context. This menu command is available only in the collaboration and attachments panes. |
| File→New→Item Element | Creates objects to represent design or manufacturing features that are not defined as part of the physical structure in the BOM. Features are implemented as item elements, sometimes called general design elements (GDEs). For information about specific item element feature types, see the appropriate application documentation. |
| File→New→Non-Revisable | Creates a new nonrevisable Tc Link connection (for example, connection or datum point connection). |
| File→New→Revisable | Creates a new revisable Tc Link connection (for example, connection or datum point connection). |
| File→New→Workflow Process | Creates a new workflow process with attachments, an associated process template and the ability to assign tasks to specific users. |
| File→New→URL | Allows you to attach a URL to an object in the structure context. This menu command is available only in the collaboration and attachments panes. |
| File→New→Envelope | Allows you to attach an envelope to an object in the structure context. This menu command is available only in the collaboration and attachments panes. |
| File→Open | Opens the selected structure. |
| File→Open With | Selects with which tool an object is opened. |
| File→Save | Saves changes made in Multi-Structure Manager. For example, you must explicitly save any modifications to BOM view revisions. |
| File→Save As→Save as New Collaboration Context | Saves the current open objects as a new collaboration context. |
| File→Save As→Item(Revision) | Saves a selected item as a new item revision. |
| File→Save As→BOM View Revision | Saves a selected BOM view as a new BOM view. |
| File→Save As→Replace Assembly in Context | Creates a new MBOM substructure (kit) from an existing one, while preserving the alignment of items within the kit. |
| File→Revise | Revises the selected item. |
| File→Close | Closes the currently displayed structure. |
| File→Print | Views, prints, or saves information about the currently selected structure. |
| File→Print... | Views, prints or saves properties, textual information, graphics or information associated with the selected item. |
| File→Unload All | Removes all structures from the collaboration pane. |
| File→Exit | Ends your Multi-Structure Manager session. |
| Edit→Cut | Marks the selected lines for removal and copy their contents to the clipboard. Cut lines are only removed once pasted elsewhere in the product structure. |
| Edit→Copy | Copies the selected lines to the clipboard. |
| Edit→Paste | Pastes item revisions from the clipboard as components of the selected lines. |
| Edit→Delete | Deletes a single item or an item and all its children. Optionally, you can also remove any associated referenced objects. This command permanently removes any selected item from the structure and the database. |
| Edit→Paste Special | Pastes components on the clipboard to the selected assembly (line). |
| Edit→Paste Substitute | Pastes item revisions from the clipboard as substitutes for the selected (assembly) lines. |
| Edit→Replace | Replaces the selected line with the item revision or item element on the clipboard. |
| Edit→Replace... | Allows you to browse for an item revision to replace the selected line. |
| Edit→Split Occurrence | Divides an assembly or part represented by the selected line into two lines, and splits the quantity between them. |
| Edit→Insert Level | Creates an item and inserts it in the current structure as a new level below the selected line. The number of relative occurrences of the children is preserved. |
| Edit→Remove | Removes the selected lines from the product structure. Any child branches of the removed line can be removed or moved up to the next level. Data including occurrences notes and absolute occurrences attached to the removed line are lost. |
| Edit→Purge | Permanently removes old versions of a dataset from the database. You can select whether to purge all old versions or specific versions of a dataset. |
| Edit→Latest | Displays the latest versions of all datasets in a selected folder. The Latest menu command updates all version-0 datasets to reference the latest saved version in the database. This feature is useful in a network environment when multiple users are working on the same dataset. |
| Edit→Change Ownership | Changes ownership of one or more objects. Using the Explore Selected Components option, you can select component objects and attachments, such as datasets, forms, and part files for ownership change. |
| Edit→Toggle In Context Mode | Enables or disable editing in context mode, allowing creation of absolute occurrences for the selected assembly. |
| Edit→Toggle In Allocation Context Mode | Allows you to assign directional relationships between specific instances of an item revision in one product structure and one or more item revisions in a related structure. |
| Edit→Variant Condition | Creates a variant condition on the selected line. |
| Edit→Toggle Precise/Imprecise | Changes the precision of the selected assembly (line). |
| Edit→User Setting | Changes your group, role or volume assignments, also your application logging and journaling options. |
| Edit→Options | Changes user interface settings that affect all applications. |
| View→Refresh Window | Synchronizes the currently displayed product structure with the database. The displayed structure refreshes with changes that have been made in other sessions and saved since you loaded the currently displayed product structure. |
| View→Expand | Expands the substructure immediately below the selected lines. |
| View→Expand Below | Expands the complete substructure below the selected lines. |
| View→Expand Below... | Expands the substructure below the selected lines to a user-selected level. You can also collapse an expanded substructure when you choose this option (hide certain child lines). |
| View→Expand to Type | Expands the substructure below the selected lines to a user-selected type. For more information, see Expand and collapse a structure. |
| View→Collapse Below | Collapses the complete substructure below the selected lines (hide all child lines). |
| View→Show/Hide Occurrence Groups | Shows or hides any occurrence groups in the structure. |
| View→Pack | Packs the selected lines so that all lines with the same item revision and find number are displayed as a single line. The actual quantity of lines appended to the node. |
| View→Pack All | Unpacks the selected packed lines so that they are displayed as separate lines, one for each occurrence. |
| View→Unpack | Unpacks the selected packed lines so that they are displayed as separate lines, one for each occurrence. |
| View→Unpack All | Unpacks all lines in the displayed structure. |
| View→Notes | Allows you to view, and edit if permitted, all occurrence notes for the selected line. |
| View→Access | Views, changes, and/or applies access permissions for a selected object. |
| View→Named References | Views, opens, imports, or exports the named references of a selected dataset. You can use the function buttons in the dialog box to cut or copy a selected reference to the clipboard and paste references from the clipboard. |
| View→Properties | Allows you to view all properties of the selected line. You can edit those properties to which you have permission. |
| View→Organization | Displays your Teamcenter organizational structure including the groups in your enterprise, the roles in each group, and the users assigned to each role. Organization Management Using Groups, Roles, and Users explains how a user with dba privileges creates and manages the information displayed in the organization chart. |
| View→Show Unconfigured Variants | Shows or hides unconfigured variant components. |
| View→Show Unconfigured Assigned Occurrences | Shows assigned objects that were configured out by the variant rules of the structures from which the objects were assigned. You can only use this command with composition structures. Note This command does not automatically refresh. Any changes to the assigned objects are not reflected in the structure until you execute this command again. |
| View→Show Unconfigured Changes | Shows unconfigured changes. If you hide unconfigured changes, only those changes configured by the current revision rule are visible. |
| View→Show Unconfigured By Occurrence Effectivity | Shows or hides components that are not configured when using occurrence effectivity. |
| View→Show Data Panel | Shows or hides the data pane. This menu command is available if the collaboration pane, structure pane, or data pane is open. |
| View→Show Collaboration Panel | Shows or hides the collaboration pane. This menu command is always active. |
| View→Show Second Structure Panel | Shows or hides the second structure pane. This menu command is always active. |
| View→Apply Occurrence Type Filter | Adjusts the display to show only the objects that you select using the Select Occurrence Type Filters command. This results in a more compact and ordered view of very large structures. |
| View→Select Occurrence Type Filter | Chooses which objects are visible in the structure. Select the object types that you want to see. |
| View→Show GCS Connection Points | Shows or hides all connection points defined for GCSs (guided component searches). GCSs are defined with the Classification Admin application. |
| Tools→Check-In/Out→ Check-Out | Checks a selected component out of the database. |
| Tools→Check-In/Out→ Check-In | Checks a selected component into the database. |
| Tools→Check-In/Out→ Cancel Check-Out | Reverts checkout. |
| Tools→Check-In/Out→ Transfer Check-Out | Transfers a selected, checked-out component to another user. |
| Tools→Check-In/Out→ Notification List | Views or edits the list of users who are informed if the selected component is checked in or checked out. |
| Tools→Check-In/Out→ Check-Out History | Views the history of check out actions for the selected component. |
| Tools→ID Display Rule→View/Set Current | Views the ID display rule currently applied to the selected structure or set a different ID display rule. |
| Tools→ID Display Rule→Modify Current | Modifies the ID display rule currently applied to the selected structure. |
| Tools→ID Display Rule→Create/Edit | Creates a new ID display rule or modify an existing ID rule. |
| Tools→Project→Assign | Assigns the selected structure to a predefined project. |
| Tools→Project→Remove | Removes the selected structure from a project to which it is assigned. |
| Tools→Revision Rule→View/Set Current | Views or sets the revision rule for the currently displayed structure. |
| Tools→Revision Rule→Set Date/Unit/End Item... | Sets the date, unit number, or end item to configure the structure, if the current rule allows. |
| Tools→Effectivity→Revision Effectivity | Views, edits, creates, or copies effectivity data for the item revision of the selected line. You must have the appropriate permissions to create or edit effectivity data. |
| Tools→Revision Rule→Set Override folder... | Sets an override folder to override item revisions that would otherwise be selected by other criteria. |
| Tools→Revision Rule→Modify Current... | Modifies the current revision rule and apply the modified rule to the current structure. You can save the change if you have write access to the original rule. |
| Tools→Revision Rule→Create/Edit... | Creates or edits a revision rule. |
| Tools→Effectivity→ Revision Effectivity | Views, edits, creates, or copies effectivity data for the item revision of the selected line. You must have the appropriate permissions to create or edit effectivity data. |
| Tools→Effectivity→ Effectivity Mapping | Views, edits, creates, or copies effectivity mapping for an end item. Effectivity mappings are needed if you implement nested effectivity. |
| Tools→Effectivity→ Occurrence Effectivity | Views, edits, creates, or copies occurrence date effectivity data for the occurrence of the selected line, or for multiple lines. You must have the appropriate permissions to create or edit effectivity data. |
| Tools→Variants→Configure Variants | Configures or edit a variant structure for the selected top-level module. |
| Tools→Variants→Only Configure Root | When on, displays options only for the top-level module, regardless of the line selected. Set to off to configure the structure for a lower level module. |
| Tools→Variants→Search | Searches for an existing variant item. |
| Tools→Variants→Count Modules | Counts the modules defined for the selected variant structure. |
| Tools→Variants→Unlink Variant Item | Unlinks a variant item from the generic module item to make changes. |
| Tools→Variants→Update Variant Items | If you make structural changes to a generic item and create a new item revision, Teamcenter does not automatically propagate such changes to each associated variant item. Choose this command to make such changes manually. |
| Tools→Accountability Check→Check | Allows you to compare two structures and view the differences (that is, how one structure uses objects compared to the other structure). This submenu is active when two structure panes are visible. |
| Tools→Accountability Check→Clear Accountability Check Display | Removes color highlights created by the accountability check. |
| Tools→Accountability Check→Propagation Settings | Allows you to modify the settings governing the propagation of properties or relations in a partial match after running an accountability check. |
| Tools→Accountability Check→Propagate | Passes along changes from the source structure to the target structure in a partial match. |
| Tools→Accountability Check→Select Unused | Runs the accountability check and shows all occurrences in the source pane that do not match an occurrence in the target pane in an occurrence group. |
| Tools→Accountability Check→Select Completely Used | Runs the accountability check and shows all occurrences in the source pane that match more than one occurrence in the target pane in an occurrence group. |
| Tools→Accountability Check→Select Over-used | Runs the accountability check and shows all occurrences in the source pane that match a corresponding occurrence in the target pane in an occurrence group. |
| Tools→Accountability Check→Partial Compare Results | Displays all properties that were included in the partial compare criteria that you set in the Partial Match Options pane of the accountability check. |
| Tools→Accountability Check→Find in Other Structure | Finds the corresponding item in the other panel and selects it. This also expands the tree automatically. |
| Tools→Multi-Site Collaboration | Controls the data shared with participating sites in a distributed network. Multi-Site Collaboration allows you to publish and unpublish objects. For more information, see Multi-Site Collaboration. |
| Tools→Import→Objects | Imports objects into the database using various import formats. |
| Tools→Import→From PLMXML | Imports objects into the database using the PLM XML format. For more information, see Systems Engineering ─ Deployment and Rich Client Usage |
| Tools→Import→Remote | Imports a structure from a remote site in a Multi-Site Collaboration environment. Search for the remote object in My Teamcenter. |
| Tools→Export→Objects | Exports objects using a Teamcenter or STEP format. You can also use this command to export an application interface object. |
| Tools→Export→To PLMXML | Exports the selected structure and its attachments in PLM XML format to a selected export directory. You must choose the appropriate transfer mode for the destination system. |
| Tools→Export→Objects to Excel | Exports the selected structure lines to an Excel spreadsheet. For more information, see Systems Engineering ─ Deployment and Rich Client Usage. |
| Tools→Export→Objects to Word | Exports the selected structure lines to a Microsoft Word document. For more information, see Systems Engineering ─ Deployment and Rich Client Usage. |
| Tools→Send Data To | Sends selected data to an external application using an application interface object. Your Teamcenter administrator uses the Business Modeler IDE application to create new application interface types associated with a specific application. Each of these types are available in the Send Data To dialog box. |
| Tools→Send Additional Data To | Sends additional data to a running session of the application launched using the Send Data To menu command. |
| Tools→Structure Search | Searches a structure using various properties of the structure's lines. The search is not limited to the loaded lines of the structure and can search an entire structure without loading it. It then expands the structure to the found lines. |
| Tools→Manage Global Alternates | Allows you to define global alternates and a preferred alternate for the selected component. |
| Tools→Repair Broken Links | Identifies broken links and searches for the possible occurrence that was originally defined, for example, as a consumed part. For more information, see About broken links. |
| Tools→Baseline | Copies work in progress (WIP) item revisions. During the development of a product design, you may need to share such copies of your working design with other users at the same or different sites. You can also save your design for future reference. For more information, see About baselining or preliminary structures. |
| Tools→Address Lists | Displays lists of users who participate in workflow processes. |
| Tools→Connect | Connects two selected lines with a revisable or nonrevisable connection. |
| Tools→Disconnect | Disconnects the currently selected line with a revisable or nonrevisable connection to another line. |
| Tools→Save Configuration | Allows you to save the current configuration of the structure pane, overwriting the structure context’s existing configuration. This menu command is available only if a structure context is opened. |
| Tools→Save as New Configuration Context | Saves the current configuration of the structure pane to a new configuration context and adds it to the structure context. This menu command is available only if a structure context is opened. |
| Tools→Set View Configuration... | Sets the structure pane’s configuration to the previously saved configuration context. This menu command is available only if a structure context is opened. |
| Tools→Restore Configuration | Resets a structure pane’s configuration back to its previously saved configuration context. This menu command is available only if a structure context is opened. |
| Tools→Assign | When two structure panes are visible, this menu command allows you to select assemblies or components in one structure and assign them to an assembly in the other structure as its children. Once this is done, the absolute occurrences of those assigned children are shared between the two structures. You can search for lines that share absolute occurrences between different structures from any instance of the assembly or component. Note You can also right-click on a selected line in the BOM and choose the Assign menu command to do this; the new line does not have an occurrence type. Alternatively, if you choose the Assign As menu command from the shortcut menu, you can choose an occurrence type for the new line that is created by the assignment from an additional shortcut menu. |
| Tools→Intermediate Data Capture | Saves the current structure configuration to a PLM XML format that you can browse and compare against existing structures. For information about creating intermediate data captures, see About intermediate data captures. |
| Tools→Validate Occurrences | Allows you to validate that a selected line and (optionally) any child lines meet the business rules defined by your administrator for structure edits. For information, see Performing on-demand validation. |
| Tools→Link Structures | Assigns occurrences in the MBOM to those in the EBOM based on absolute occurrence ID properties. |
| Tools→Structure Alignment→Completeness Check→Verify Part Structure | Highlights all part occurrences that are aligned with positioned designs in green. Part occurrences that do not have links to positioned designs are highlighted in red. |
| Tools→Structure Alignment→Completeness Check→Clear Display | Removes highlighting after performing a completeness check. |
| Tools→Structure Alignment→Publish Data | Creates a snapshot of transformation and shape information on a source design occurrence and publish it to the destination part occurrence. |
| Tools→Structure Alignment→Create PublishLink | Aligns part and design by creating a publish link between the selected occurrences |
| Tools→Structure Alignment→Delete PublishLink for source | Removes the link between occurrences aligned between part and design. |
| Tools→Structure Alignment→Add Target to PublishLink | Adds a new target part occurrence to a publish link. |
| Tools→Structure Alignment→Remove Target from PublishLink | Removes a target part occurrence from the selected publish link. Removing the target of the publish link does not delete the part occurrence or the publish link. |
| Tools→Structure Alignment→Find PublishLink Source | Identifies all publish links for which the selected occurrence is a destination. It highlights the linked occurrences in the companion pane. If it does not find any publish links, it displays an error message |
| Tools→Structure Alignment→Find PublishLink Targets | Identifies all publish links for which the selected occurrence is a source. It highlights the linked occurrences in the companion pane. If it does not find any publish links, it displays an error message |
| Tools→Structure Alignment→Open PublishLink source structure | Opens source structure in the structure pane. |
| Tools→Structure Alignment→Find lines with same logical identity | Highlights all lines with the same logical identity as the selected line, that is, lines that are associated with it by a publish link. |
Source: https://docs.sw.siemens.com/en-US/doc/282219420/PL20251212545240207.plm00043/cca0255 · retrieved 2026-07-11