Creating, viewing, and editing manufacturing documentation > Creating a portfolio
Publish a portfolio to HTML
You can publish a portfolio on a Web server by exporting its contents in HTML format. This allows consumer users access to work instructions or product manuals from any Web browser.
Procedure
Choose File → Publish Zip to Database.The system displays the Publish to HTML Options dialog box.
Edit the export options in these ways:
Tab Options Description General tab Destination Folder Specify the destination folder where the export data is written by clicking Save. Note Specifying the destination folder is the only required selection in this dialog box. All other options in this dialog box are discretionary selections. Create zip file Create a ZIP file of all export data. Click the Browse button to specify the location of the ZIP file. Use this option to allow users without access to Teamcenter to view the data. Use title page template Use a template file for the main HTML title page. Click the Browse button to choose the HTML file. Replace or remove logo By default, the HTML output includes the Siemens Digital Industries Software logo. To replace the default Siemens Digital Industries Software logo graphic, click the Browse button to locate a replacement graphic. To remove the default Siemens Digital Industries Software logo graphic, click the Remove button. Export Options tab Stop if error occurs Stop the export operation if an error is encountered. Produce flat output Remove the portfolio structure and document hierarchy. Publishing options Indicate specific control panes to be included in the HTML output for each published page. Choose Show Details to display custom shape properties. Choose Go to Page to include navigation for multi-page work instructions or product manual. Choose Search to enable the ability to search shapes. Choose Pan and Zoom to enable panning and zooming on a page. Note The Publishing Options option is only applicable if you select VML for the Output format (VML is the default). VML output only displays Publishing Options if you use the Internet Explorer browser. Advanced Options tab Output formats Choose the primary output format for the exported published pages. Provide alternate format for older browsers Indicate a secondary output format for exported published pages, used for older browsers. Display options Select a target monitor size.Click OK.The Report Definition wizard displays the status of the export operation.
Note Name lists the supporting documents in the portfolio; Status indicates if the supporting documents were exported.
Click Next. The system displays the Create Report Output dialog box.
Create a standard or custom report output format.
Source: https://docs.sw.siemens.com/en-US/doc/282219420/PL20251212545240207.plm00043/pub0406 · retrieved 2026-07-11