ManufacturingKnowledge

Getting started > Resource Manager interface, commands, and buttons

Resource Manager menu commands

Menu command Purpose
File→New→Resource Creates the root node for a new resource in the Resource view.
File→New→Dataset Creates a new dataset and attaches it to the selected object in the resource structure. You can see the new dataset in the Attachment view.
File→New→Workflow Process Creates a new workflow process with attachments and an associated process template and allows you to assign tasks to specific users.
File→Search→Search by Classification Dialog Opens the Classification Search Dialog to help you find a classified resource. Results are displayed in the Table view.
File→Search→Search by ID Runs an object ID search that searches through the entire database for the specified resource and opens the results in the Classification Table view.
File→Close Closes the Resource Manager application.
File→Open Opens the selected object.
File→Save As Saves the selected item revision as a new revision with a new name and a revision ID.
File→Revise Creates a new item revision of the selected line.
File→Revise (incl. Super-Assemblies Revises a component including all latest revisions of super-assemblies containing that component.
File→Unload All Closes all structure panes and unloads them from Resource Manager.
File→Exit Closes the Teamcenter application.
Edit→Cut Cuts the selected lines from the resource and places them on the clipboard.
Edit→Copy Copies the currently selected resource to the clipboard.
Edit→Paste Pastes the contents of the clipboard underneath the currently selected resource.
Edit→Delete Deletes the current resource from the database.
Edit→User Setting Changes your group, role, or volume assignments, and your application logging and journaling options.
Edit→Options Changes user interface settings that affect all applications.
Edit→Edit Resource Activates edit mode so you can make changes to the current resource.
Edit→Save Resource Saves the current resource.
Edit→Cancel Edit Returns the display to show mode by canceling edit mode and deleting all changes made in the edit session.
Edit→Delete ICO for current resource Deletes the classification object from the selected resource. This does not delete the item.
Edit→Add Classified Component Opens the Classification Search Dialog so you can add a new component to the current resource.
Edit→Guided Component Search Runs a guided component search.
Edit→Remove Removes the current line from the resource. This does not remove the component from the database.
View→Show/Hide CSYS Lines Displays and hides the coordinate system lines in the structure.
View→Show GCS Connection Points Displays and hides the plug and socket symbols from which you can start a guided component search. You can choose to display all connection points or only those that are not yet connected to a component.
View→Properties Views and edits all properties of the selected line.
View→Notes Views and edits all notes for the selected line.
View→Pack Packs the selected lines so that all lines with the same item revision and find number are displayed as a single line. The actual quantity of lines is appended to the node.
View→Unpack Unpacks the selected packed lines so that they are displayed as separate lines, one for each occurrence.
View→Propagation Start Point Assigns a propagation start point to the currently selected resource. Attributes are propagated from the propagation start point up the hierarchy to the root of the structure. Only one propagation start point is allowed per structure. If you choose this menu command a second time, the propagation start point is removed.
View→Refresh Window Reads information from the database and updates the information displayed in the workspace area.
View→Expand Below Expands the complete substructure below the selected lines.
View→Collapse Below Collapses the complete substructure below the selected lines (hides all child lines).
Tools→Project→Assign Assigns the selected structure to a predefined project.
Tools→Project→Remove Removes the selected structure from a project to which it is assigned.
Tools→Revision Rule→View/Set Current Views or sets the revision rule for the currently displayed structure.
Tools→Revision Rule→Set Date/Unit/End Item Sets the date, unit number, or end item to configure the structure, if the current rule allows.
Tools→Revision Rule→Set Override Folder Sets an override folder to override item revisions that would otherwise be selected by other criteria.
Tools→Revision Rule→Modify Modifies the current revision rule and applies the modified rule to the current structure. You can save the change if you have write access to the original rule.
Tools→Revision Rule→Create/Edit Creates or edits a revision rule.
Tools→Import Imports objects into the database using PLM XML format.
Tools→Export Exports the selected structure and its attachments in PLM XML format to a selected export directory. You must choose the appropriate transfer mode for the destination system
Tools→Create Graphics Creates graphics based on a part family template or Tcl macro.
Tools→Import catalog 3D model for current resource Imports a STEP 3D model from a vendor tool catalog.
Tools→Create/Update NX Tool Assembly Part File Creates or updates the NX tool assembly part file after you create a tool assembly.
Tools→Map ICO Maps a resource from one class to another.
Tools→Create Item for ICO Creates an item for a classification object. Choosing this menu command automatically classifies the new item.
Tools→Classify Item Classifies the item of the selected line, if it is not already classified.
Tools→Classify Item Revision Classifies the selected item revision, if it is not already classified.
Note The Graphics menu appears only if you open the Graphics view.
Graphics→Selection→Select All Selects all the objects displayed in the viewer.
Graphics→Selection→Select None Clears any objects currently selected in the viewer.
Graphics→Selection→Reverse Selection Selects all objects not selected in the viewer, while simultaneously unselecting any objects currently selected in the viewer.
Graphics→Visibility→View Selected Blanks and unblanks objects loaded in the viewer. Note The term loaded refers to an object whose JT file has been loaded in the viewer. A loaded object may or may not be visible, depending on whether it is blanked or unblanked.
Graphics→Visibility→Blank Selected Makes any objects selected in the viewer invisible.
Graphics→Visibility→Blank All Makes all objects in the viewer invisible.
Graphics→Visibility→Unblank All Makes all objects loaded in the viewer visible.
Graphics→Visibility→Reverse Blank All Makes any currently visible objects invisible, while simultaneously making visible any loaded objects that are currently invisible.
Graphics→Visibility→Unload Selected Unloads any objects selected in the viewer.
Graphics→Edit Color/Translucency Modifies the color, transparency, and shine of selected objects in the viewer. These settings only apply to the currently loaded objects. The next time the edited object is loaded, the settings revert to the default color and translucency.
Graphics→Insert Allows you to insert JT, stereolithography (.stl) and VRML (.wrl) files as reference graphics.
Graphics→Insert→Insert from File Inserts a reference graphic from the operating system, using the Open by Name dialog box.
Graphics→Insert→Insert from Clipboard Inserts a reference graphics object from the clipboard. Note Only item revisions (not items) can be displayed as reference graphics.
Graphics→Views→View Control Creates, edits, and displays standard views, using the Rotate and Standard Views dialog boxes.
Graphics→Draw Children Displays the components of a subassembly. You can also access this command if you right-click in the BOM.
Graphics→Show Subcomponents Breaks down solids in the corresponding monolithic JT files and make the subcomponents independently controllable. This function is available only for leaf and unpacked BOM line nodes.
Graphics→Hide Subcomponents Removes all merged subcomponents and the one-level tree from the tree. You can load or unload the monolithic JT file related to this structure line node in the normal way.
Graphics→Export 3D File Exports the current visible objects to a STEP or VRML file.
Graphics→Replace JT File Replaces the JT file that represents an item revision. You can choose a replacement file from one of the JT files associated with the current structure line item.
Graphics→Clearance→ Preferences Sets clearance analysis and preferences.
Graphics→Clearance→Toggle Results Window Shows clearance results in a separate window.
Graphics→Performance Sets rendering, culling, and general performance preferences.
Graphics→Preferences Sets clearance analysis and general viewer preferences.

The following menu commands are shown in the view menu of the primary resource view.

Menu command Purpose
Show Graphics Opens the Graphics view that displays visualization data associated with the selected structure. The Graphics view remains associated with the primary view from which it is opened.
Show Information Displays configuration information about the open structure.
View/Set Current Revision Rule Views or sets the revision rule on the currently selected line.
Set In Context Enables you to set the currently selected structure as the context for additional information set on child objects. For example, you can add an occurrence note to a child line in the structure that is only pertinent in the context of the currently selected structure line.
Unload Unloads the current structure.
Show/Hide CSYS Lines Displays and hides the coordinate system lines in the structure.
Show/Hide GCS Connection Points Displays and hides the plug and socket symbols from which you can start a guided component search. You can choose to display all connection points or only those that are not yet connected to a component.
Show Suppressed Occurrences Displays and hides lines that are hidden by variant settings, configuration, or explicitly setting the bl_occ_is_suppressed property.

Source: https://docs.sw.siemens.com/en-US/doc/282219420/PL20251212545240207.resource_mgr/xid488459 · retrieved 2026-07-11